dev.hel.fi

Only TLS 1.0 Supported

The production interface uses only TLS 1.0. Some clients fail negotiate the SSL/TLS version with the production interface. This can be bypassed by forcing TLS 1.0 use on client application. This has been now fixed for example in Python Three library (see pull request).

If you are using PHP and cULR, this can be bypassed for example like this:

$ch = curl_init();

$opts = array(  CURLOPT_URL => $url,

        CURLOPT_RETURNTRANSFER => 1,

        CURLOPT_TIMEOUT => 4,

        CURLOPT_SSLVERSION => 1);

curl_setopt_array($ch, $opts);

$data = curl_exec($ch);

If you have examples on other languages post them here so others can learn from them.